当前位置:首页 > 问答

通达信压力支撑指标源码

我来帮TA回答

跪求通达信分时压力,支撑,主图公式!

突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,10,0),COLOR000099;
STICKLINE(A1X<0,空方,突破,10,0),COLOR00CC66;
EE:=(H+L+O+2*C)/5;
CRTP:=EE+(H-L);
CRZL:=2*EE-L;
CRZC:=2*EE-H;
CRFZ:=EE-(H-L);
顶:CONST(CRTP),COLORRED;
压:CONST(CRZL),COLORC7C9FF;
撑:CONST(CRZC),COLOR7C9CFF;
跳:CONST(CRFZ),COLORDD00DD;
弹:MA(CLOSE,3);
支撑:EXPMA(CLOSE,40);
起涨:MA(C,13),COLOR00FFFF,LINETHICK2;
涨:IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,13)=REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(CLOSE,13)<REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORGREEN,LINETHICK2;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR,跳 , '跳起'),LINETHICK1,COLORDD00DD;
DRAWTEXT(ISLASTBAR,撑 , '撑力'),LINETHICK1,COLOR7C9CFF;
DRAWTEXT(ISLASTBAR,压 , '压力'),LINETHICK1,COLORC7C9FF;
DRAWTEXT(ISLASTBAR,顶 , '顶破'),LINETHICK1,COLOR0000FF;
A:MA(C,10)<MA(C,24) AND COUNT(CROSS(MA(C,5),MA(C,10)),10) AND REF(L,1)<REF(MA(C,10),1) AND REF(C,1)<REF(MA(C,5),1) AND C>REF(H,1) AND REF(C,1)<REF(H,2) AND COUNT(MA(C,10)>REF(MA(C,10),1),5)>1,NODRAW;
B:MA(C,10)>MA(C,24) AND REF(L,1)<REF(MA(C,24),1)*1.01 AND C>REF(H,1) AND REF(C,1)<REF(H,2) AND REF(C,1)<REF(H,2),NODRAW;
DRAWICON(A,L-0.10,16);
DRAWICON(B,L-0.10,17);
HH:=LLV(L,7)*1.13-0.03;
STICKLINE(H>=HH,H,H*1.005,1,0),COLOR00FFFF;
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
日跌:L*0.989,NODRAW,COLORFF00FF;
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P11:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P22:=今小前;
DL:=P11=1 AND REF(P11,1)=0 AND P22=1 AND REF(P22,1)=0;
STICKLINE(DL,O,C,0.1,0),COLORAAAAAA;
BB :=MAX(C,O)-(REF(MAX(C,O),2)-MAX(C,O))/2;
买点:=(H-(REF(H,2)-H)/2);
AA:MAX(BB,买点),NODRAW,COLORFF00FF;
STICKLINE(C<O AND F<-3 AND F>-5,C+(O-C)/3,C+(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<-3 AND F>-5,C+2*(O-C)/3,C+2*(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<=-5 AND F>-7,C+(O-C)/2,C+(O-C)/2,2.5,0),COLORYELLOW;
STICKLINE(C<O AND F<=-7 AND F>-10,C+2*(O-C)/3,C+(O-C)/3,2.5,1),COLORYELLOW;
STICKLINE(C<O AND F<=-9.9,O,C,2.5,0),COLOR00FF00;
STICKLINE(C>O AND F>2.9 AND F<5,O+(C-O)/3,O+(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>2.9 AND F<5,O+2*(C-O)/3,O+2*(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=5 AND F<7,O+(C-O)/2,O+(C-O)/2,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=7 ,O+2*(C-O)/3,O+(C-O)/3,2.5,1),COLORYELLOW;
A1:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B1:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B1,B1,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),COLORWHITE,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;
IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);
IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头};

通达信支撑压力线指标源码怎样改成文华期货指标

uy通达信支撑压力线指标源码怎样改成文华期货指标

RSI看趋势看支撑看压力看背离通达信指标公式源码

(20-15)/15=33.333333%

有通达信的压力位与支撑位的指标公式吗?望提供,谢谢!

其实,传统的布林带就是最好的压力于支撑指标了!
你在K线图输入BOOL就出来。

怎样通过指标寻找主升浪的启动点

在选股尤其是选强势股方面,MACD有着非常重要的作用,如果运用得好,可以成功地捕捉到行情主升浪的起涨点,其方法如下:
首先是调整所用分析软件中有关指标的参数,即移动平均线时间参数设定为5、10、30,它们分别代表短期、中期、长期移动平均线;成交量平均线参数设定为5、10;MACD中的快速E-MA参数设定为8,慢速EMA参数设定为13,DIF参数设定为9.
调整好指标参数之后,便是根据合理、科学的指标组合来设定选股条件。实践证明,满足“MACD连续二次翻红”的股票往往会有非常好的上涨行情。所谓 “MACD连续二次翻红”,是指MACD第一次出现红柱后,还没等红柱缩没变绿便又再次放大其红柱。这是利用MACD选股的关键。

如果一只股票的走势符合这一总则,同时又符合以下四个条件,那就意味着该股票出现大幅上涨行情的可能性非常大:
一、30日移动平均线由下跌变为走平或翘头向上,5日、10日、30日移动平均线刚刚形成多头排列;
二、股票的日K线刚刚上穿30日移动平均线或在30日移动平均线上方运行;
三、MACD第一次翻红的红柱越短越好,一般不过多超过0轴上方的第一横线;
四、成交量由萎缩逐渐放大,当日成交量大于5日平均量。

特别需要说明的是,买入后成交量必须连续放大;买入后MACD的DIF值必须连续递增,如果不符合这两个条件,就要及时出场。这些在以后的操作中可以慢慢去领悟,为了提升自身炒股经验,新手前期可以用个牛股宝模拟炒股去学习一下股票知识、操作技巧,对在今后股市中的赢利有一定的帮助。希望可以帮助到您,祝投资愉快!

请老师把“绝对主升”指标改为同花顺能用的,谢谢老师。

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
五强:=MA5>REF(MA5,1),;
十强:=MA10>REF(MA10,1),;
小均强:=五强 AND 十强,;
强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60);
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20);
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10);
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13);
开始走强1:=强势线1>REF(强势线1,1),;
开始走强2:=强势线2>REF(强势线2,1),;
开始走强3:=强势线3>REF(强势线3,1),;
开始走强4:=强势线4>REF(强势线3,1),;
双强1:=开始走强1 AND 开始走强2,;
双强2:=开始走强2 AND 开始走强3,;
双强3:=开始走强2 AND 开始走强3,;
双强4:=开始走强3 AND 开始走强4,;
三强:=开始走强1 AND 开始走强2 AND 开始走强3,;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4,;
强势为王:=双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强,;
VV:=(C+L+H)/3;
DSA:=SMA(XMA(VV,15),2,1);
底部1:=DSA*0.9518;
猎股小王:=L<底部1 AND C<DSA AND 强势为王;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
五日走强:=MA1>REF(MA1,1),;
十日走强:=MA2>REF(MA2,1),;
二十日走强:=MA3>REF(MA3,1),;
六十日走强:=MA4>REF(MA4,1),;
低位主升:=五日走强 AND 十日走强 AND 六十日走强,;
主升浪:=五日走强 AND 十日走强 AND 二十日走强,;
大主升浪:=十日走强 AND 二十日走强 AND 六十日走强,;
大主升浪2:=五日走强 AND 十日走强 AND 二十日走强 AND 六十日走强,;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2,;
总主升浪:=低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升,;
强势主升低买:L<底部1 AND 总主升浪 AND 强势为王 AND C<DSA;
猎股大王出击:=强势主升低买 AND 猎股小王 AND H<DSA;
A:=MA(C,30);
A1:=A*1.1;
A4:=A*0.9;
A2:=A1-(A1-A4)*0.191;
持仓:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A1,A4);
生命线:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A2,A4);
主升1:=持仓>REF(持仓,1),;
主升2:=生命线>REF(生命线,1),;
主升:=主升1 AND 主升2,;
主升持仓:=持仓>生命线,;
主升猎股王:=(猎股大王出击 AND 主升持仓 AND 主升) OR (猎股小王 AND 主升持仓 AND 主升),;
绝对的主升:(主升猎股王 AND 小均强) OR (猎股小王 AND 小均强);